Peugeot 208 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Has anyone else experienced their touchscreen freezing and the music playing from a USB getting stuck? This happened to me today, a song was playing until it stopped at a certain point and got "stuck" like an old record would. I tried every button I could to try and get out of it, pulled the USB out, I even turned the ignition off and took the key out!! and it still kept playing the stuck music even though the screen had no power to it any more. I really thought i was going to have this 2 second clip playing forever lol! Then after a short while of it driving me crazy, the speakers made 2 very loud POP sounds and the music finally stopped. This was not a good sound and I really thought my speakers had blown, but after I turned the ignition on again the touchscreen came back on (slowly) and all was well again. Its worked fine since so am hoping it was a one off crash maybe, but just wondered if anyone else had this happen to them ?
 

·
Registered
Joined
·
18 Posts
Yeah I had this issue. I was using a USB stick with my music on was fine then I loud pop and the screen crashed then look ages to load. I've changed to an iPod now and all seems to be fine
 

·
Registered
Joined
·
10 Posts
Just got my 208 on Saturday and I've noticed that the music functionality of the touch screen leaves a lot to be desired!

I've not used it with a USB stick yet, but here's a few things that aren't too good when plugging in an iPod:

* It "stutters" every now and then. That is, especially when I am using the touch screen, it cuts out for a fraction of a second.
* You can't browse by album artwork with an iPod. You have to just browse by song names. It shows the album artwork of the currently playing song, so I don't see why it wont let you browse by artwork too, especially when you can with a USB stick.
* It's slow to respond. Browsing for a new album to play is a very slow and tedious task.
* You can't even browse the songs on your iPod instead when it's plugged in because it locks the screen and says "accessory connected".

Let's hope these issues get fixed via an update or something.

Apart from that though, I love the car - beautiful exterior and interior!
 

·
Registered
Joined
·
8 Posts
Suggest you might have old software in the touch scree. There are 3 versions.
Soft: 3.0.H.R6
CD: 11226
Date: 27-01-2012
Soft: 3.0J.R7
CD: 11236
Date: 02-04-2012
Soft: 3.0.K.R4
CD: 11243
Date: 27-07-2012
Press and hold menu key for a few seconds to see which you have. Ask dealer to upgrade software if necessary. In any case report the problem to your dealer.
 

·
Registered
Joined
·
8 Posts
Yes we have had an identical problem like yours and even
worse in that six months later we are still locked in with our local Garage
trying to resolve an ongoing screen freezing problem that is very erratic in
nature and extremely frustrating when you consider how much we are paying for
the brand new car (208 XY). Car and touch screen system ran lovely up to the
first 1000mile servicing check and now we appear to have random freezing of the
screen. Upgrades to the software have been carried out and even the multi
functional screen has been changed to no effect. If anyone has more information
that might help us solve this problem please contact us. PS. We have managed to obtain video evidence of
this happening which has been forwarded to Peugeot.
 

·
Registered
Joined
·
8 Posts
Glad to say my garage managed to get Peugeot to agree to a replacement, and I have had no further problems. Keep pushing them !
 

·
Registered
Joined
·
31 Posts
My 1.2 Allure (Had it new since March) randomly reports 'system faulty' on the touch screen & you have to push on of the physical buttons to the left of the screen to clear it.

It's booked in on Monday for them to look at this and a few other niggles, including gear shift indicator showing up and down arrows all the time, unless it's telling you to shift up or down - in which case the arrow changes - to up or down!
 

·
Registered
Joined
·
11 Posts
mines booked in again got Monday. Did it this time last year when the weather was cold. Last night the screen just went off completely.
 

·
Registered
Joined
·
31 Posts
If you can find my other post you will see it's a common problem, lots of owners having the same issue.

I've been told they have placed a screen on order and are waiting for this to be delivered. From what i'm reading elsewhere this has already started to happen and has fixed the problem.

I'll wait and see.
 

·
Registered
Joined
·
8 Posts
Hi! Came across your problem on investigating ours and the two loud POP sounds was exactly what we had when we first started having problems and shortly after this sound our system would recycle for no reason, almost as if the POPs was some sort of sort to earth sensed by the speakers and this short would then have been picked up by the computer as a re-set.We are currently locked in negotiations with Peugeots to try and resolve our Multi Functional Screen problems, hopefully your problem was a one off but thanks for posting every little bit helps.
 

·
Registered
Joined
·
9 Posts
I also have a problem with my touch screen not only does it freeze but also appears to have moisture behind the screen,as anyone else Had this problem?
 
1 - 13 of 13 Posts
Top