Peugeot 208 Forums banner
21 - 26 of 26 Posts

·
Registered
Joined
·
1 Posts
I have no idea if temperature is a problem - I live in Scotland and it doesn't really get too hot here.

follow this link - you should see that fuse number 18 of the dashboard fuses of the left of the car is for the touchscreen. I removed number 17 too and put it back in.
Peugeot 208 Fuse Box Diagram

Remove the fuse for a few seconds - put it back in and it should reset the touchscreen - that's all i did and i had no problems.
This worked like a charm, once I'd left the ignition on before removing and replacing no 18 fuse. Dealership wanted £100 min +vat
 

·
Registered
Joined
·
1 Posts
Hi,

Going through a million fuses! Anyone have a long term solution to this??
it's not the fuses that are faulty (typically). Just pull the fuse out and pop it back in and that resets the unit.

I bought a 13 208 3 months ago. Same problem! no real answer on this forum. However, removal and clean of SMEG unit and stretching of fan spring contacts appears to have fixed one owners problem.

Might try that.
 

·
Registered
Joined
·
2 Posts
it's not the fuses that are faulty (typically). Just pull the fuse out and pop it back in and that resets the unit.

I bought a 13 208 3 months ago. Same problem! no real answer on this forum. However, removal and clean of SMEG unit and stretching of fan spring contacts appears to have fixed one owners problem.

Might try that.
Did you try that and did it work? I’ve got the same problem, removing the fuse worked but stopped working again the next morning..
 

·
Registered
Joined
·
2 Posts
Did you try that and did it work? I’ve got the same problem, removing the fuse worked but stopped working again the next morning..
Did u leave the ignition on. I had a similar problem with the car switched off. I have now removed the fuse with the car running (as per a previous post) and all seems good at the moment
 

·
Registered
Joined
·
2 Posts
Will try tomorrow. Is that safe? 🤷‍♂️
Hi mate- yes that is safe. U r only dealing with low voltage. I generally use long nose pliers to remove the fuses just to be on the safe side. I do a driving job in the evening so my car is stop start. I have only recently got the car and it was really annoying me. I tried it with the car running and it has been fine for 48 hours so fingers crossed it’s sorted. I saw your post on here and thought I would share this info so I registered to update u just in case it helps and I would hate for other people to have the same issue as me. I will let u know if the problem comes back
 
21 - 26 of 26 Posts
Top