Peugeot 208 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
I, like many others, are waiting for a new shiny touchscreen to be delivered to the dealer ('Peugeot know about the problem', and 'we are awaiting delivery, they are on order') so that it can be fitted and all our problems will go away.

Or will they?

Anyone had a replacement screen fitted - has it fixed the problem?

Any notice in improved performance of the system?
 

·
Premium Member
Joined
·
474 Posts
I had mine updated the other week and is was fine untill sat night when it froze again. The cause is cold weather. A friend who works at Peugeot says he has a few second hand ones that has been left in the yard unused that have had to have them replaced.
 

·
Premium Member
Joined
·
81 Posts
Hi Duffy,

Thanks for letting us know about your experience. It is worrying though, I am waiting for a replacement screen and pretty much asked the same question as miffy93 in another thread. Apparently some owners had their screens replaced early last year and hadn't seen any issues since, but my concern was that was not proof of a fix, simply that the weather hadn't been cold enough since.

With the delays in getting the replacement touchscreens, it is likely the spring will come and people won't know that a fault still exists. I think Peugeot are being really ignorant and unreasonably lazy in diagnosing this issue. With many owners experiencing the same symptoms they shouldn't just be replacing screens, they should be doing proper problem management and diagnosing the root cause for an official fix. All the dealers are currently doing is attempting to remove the problem by process of elimination and it's extremely inefficient and time wasting.

I'm fearful that if I still have this car by the end of this year (looking more and more unlikely - saving to replace with a fiesta) then the symptoms will reappear and it'll mean more time and expense taking it back to the dealer again and again.
 

·
Registered
Joined
·
6 Posts
I had my screen replaced 3 weeks ago, having been waiting since the first week of January. The car is due booked into the Garage next week as it has now developed a problem with the SatNav turning strange colours and Bluetooth failing. Caused an awful staitc popping noise through the whole sound system. Its the 5th time it has been in for a touch screen issue, and the 7th time for an "electrical" issue. I got the car second hand in November last year. I can see why it was traded in.
 

·
Registered
Joined
·
15 Posts
I had mine re placed last month had no problems and only waited 3 weeks for it. But as said above it has not been cold enough to see if it is fixed.
 

·
Registered
Joined
·
6 Posts
True, I had the problem with it being cold, but then again I had the whole thing pack up on me and then the dealer couldn't update the SMEG to stop it feom happening. So they replaced the screen. And its broken again. Not happy.
 

·
Premium Member
Joined
·
152 Posts
True, I had the problem with it being cold, but then again I had the whole thing pack up on me and then the dealer couldn't update the SMEG to stop it feom happening. So they replaced the screen. And its broken again. Not happy.
Is black screen problem happening even with brand new Smeg unit?

What a shame!
 
1 - 8 of 8 Posts
Top