Peugeot 208 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all, my first post.
My son has not had his 208 long but a few weeks after he got it the engine warning light came on and it appeared to lose some power. Had diagnostic was told it was spark plugs that were subsequently replaced. A few weeks later the engine line comes on again diagnostic done somewhere else points to spark plugs. Looking at service history a few diagnostics have been done and spark plugs changed at least three times. The car has only done 26.000 miles. The engine light still comes on from time to time but yesterday the car seemed to bounce up and down and no power. Does anybody have any ideas?
 

·
Premium Member
1991 205 GTi 1.9 Red ; 2014 208 GTi AE #071 White
Joined
·
382 Posts
Try everything associated with the plugs... leads, coils etc. Do you know what the exact code was?
 

·
Registered
Joined
·
7 Posts
Ridiculous to change spark plugs so many times - very unlikely to be them anyway. I'd guess the diagnosis is a misfire. It won't be coils (NB no leads - the coils sit on top of the plugs). One possibility is the camshaft position sensor. They are a bit flaky. Quite cheap to buy (~£25 if you shop around) but a pain to replace. It's at the back of the cylinder head at the left hand end (from driver's seat) - behind the air filter/intake gubbins. Just one bolt - but it's very inaccessible.

Changing it worked on my daughter's 208 1.2 - similar symptoms.
 
1 - 4 of 4 Posts
Top