Peugeot 208 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hey all

I have had my 1.2 allure for 5 months and done just over 2000 miles now. Since getting the car I have been experiencing what I would describe as an engine judder/vibration which is present through gears and when at a constant speed, booked in to be checked on Friday, have not done anything as yet as I was advised to let engine bed in !!!! Any ideas or has anyone experienced this? Due to get touchscreen sorted as well as getting the gps fault (no sat nav!!!) and it's jumpin between screens ! Must say loving the car though!
 

·
Registered
Joined
·
5 Posts
Pug178,

My engine has been juddering when I have the speed limiter on specifically but due to me having it on most of the time I haven't compared it to when I haven't.

Does your's appear to become almost unresponsive under acceleration, almost as if someone is stamping on the acceleration pedal over and over again?

I'd be interested to see what the dealer said...

Thanks,

Wiggles89
 

·
Premium Member
Joined
·
69 Posts
And a lot of them show a GPS fault - even without Sat Nav , mainly when it's cold , A lot of faults with touchscreen !
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Well the car went in and was driven by a mechanic who specialises in another car brand and he said that it was driving fine and the judder was due to the engine being 3 cylinder and having to work harder (mmmm) , told not to worry as it would have been checked before collection and at least I have reported that there could be a problem so if there is a bigger problem as a result in the future it's not on me !!!!!! I asked for it to be checked in the workshop and was told there was no need and the Peugeot mechanic was too busy. But the mechanic was able to fit in my car to do the touch screen a few days later , engine not checked, as for the touch screen they ran an update but as its been a bit warmer don't know if probs been resolved , funny thing is my 5th gen iPod that didn't work before does now and the shuffle I was using doesn't. Engine still juddering nicely and just received a request to complete an after sales satisfaction survey , let's see what happens..........
 
1 - 5 of 5 Posts
Top