Peugeot 208 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey everyone, first post so please be gentle :)

Picked up a 63 plate 208 Allure yesterday, got it home (was a bit of a trek, about 100m or so) and as I was right near home I had a few beeps and an ‘engine fault repair needed’ pop up in the middle, and the service light came on but not the EML. After I parked and turned off for a few mins, turned over again and it’s gone with no fault found when I push the button on the dash. Has anyone had any issues with this in the past? The EML turns off after the car is turned over.

Also, the clutch is really high - like nearly level with the brake high - so I’m assuming it’s highly possible this would mean the clutch needs replacing?

Thanks for all your help
 

·
Registered
Joined
·
2 Posts
Hey everyone, first post so please be gentle :)

Picked up a 63 plate 208 Allure yesterday, got it home (was a bit of a trek, about 100m or so) and as I was right near home I had a few beeps and an ‘engine fault repair needed’ pop up in the middle, and the service light came on but not the EML. After I parked and turned off for a few mins, turned over again and it’s gone with no fault found when I push the button on the dash. Has anyone had any issues with this in the past? The EML turns off after the car is turned over.

Also, the clutch is really high - like nearly level with the brake high - so I’m assuming it’s highly possible this would mean the clutch needs replacing?

Thanks for all your help
Hello, not sure bout the light, i have ownee 3 pugs, all clutches high just the way they are from what i know and what pug have told me, currently have 66 plate, never had issues with clutches, my partner hates driving it as he says to high could be wrong but think its just design?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Hello, not sure bout the light, i have ownee 3 pugs, all clutches high just the way they are from what i know and what pug have told me, currently have 66 plate, never had issues with clutches, my partner hates driving it as he says to high could be wrong but think its just design?
Hi there,
Fair enough and thanks, it’s going in to a mechanic this morning to be looked at so hopefully it’s just a sensor that’s gone somewhere.
Otherwise I’m gonna have a fun repair bill ?
 

·
Registered
Joined
·
4 Posts
hi, what was the problem did you solve?

Hi there,
Fair enough and thanks, it’s going in to a mechanic this morning to be looked at so hopefully it’s just a sensor that’s gone somewhere.
Otherwise I’m gonna have a fun repair bill ?
 
1 - 4 of 4 Posts
Top