Peugeot 208 Forums banner
481 - 489 of 489 Posts

·
Registered
Joined
·
1 Posts
Hi everybody. I am a new Peugeot 208 owner. I have Peugeot 208, 2012 version, and I have SMEG audio unit. I wanted to upgrade the unit to the latest firmware 3.21 R1. (I had v.3.0)

1. I formatted a USB drive in FAT32
2. Downloaded latest firmware 3.21 R1
3. Extracted inside the USB stick
4. Turned engine on
5. Inserted USB
6. Unit recognized the update file
7. Message appeared that I have "this version" and will updated to "that version"
8. System rebooted
9. Bluescreen appeared with update details
10. System started "file check"
11. After 1-2 minutes check reached 100%
12. Message prompt " System must reboot" 5,4,3,2,1
13. Screen went black.... System DEAD.

Waited for around 20 minutes with engine on but nothing happened

What I have tried
1. Press buttons to hard reset unit (nothing happened)
2. Disconnect car's battery (nothing happened)
3. Disconnect car's battery for more than 2 hours (nothing happened)
4. Formatted USB using Rufus in order to create autorun files along with the firmware files. (nothing happened)
5. Removed fuse 18 and insert it again (nothing happened)

Any ideas before going to a Peugeot dealer? Thank you in advance

go to dealer radio ain't gonna work after a firmware fail

you shouldn't mess with a firmware update once dead that tends to be that (new radio time big cost)
 

·
Registered
Joined
·
3 Posts
go to dealer radio ain't gonna work after a firmware fail

you shouldn't mess with a firmware update once dead that tends to be that (new radio time big cost)
Hello all,
So I have a bricked Smeg v. 30HR6 Navi and each unit spare number 98 018 431 80

I found a pre-used part of a SMEG+ Navi unit
v. 52CR1 with spare part number 98 110 655 80

also I can find SMEG+ non-Navi
v. 52CR1 with spare part number 98 110 661 80

Is it going to work by keeping the same display? The connectors at the back are the same. I tried to talk with 4 different Peugeot distributors here in Greece but no one was able to answer my question. They do not know if it is going to be compatible.
Only one person told me that it should work, but then you have to go to Peugeot service and match new unit with new VIN since the unit is going to beep all the time.

Thank you in advance
 

·
Registered
Joined
·
96 Posts
Hello all,
So I have a bricked Smeg v. 30HR6 Navi and each unit spare number 98 018 431 80

I found a pre-used part of a SMEG+ Navi unit
v. 52CR1 with spare part number 98 110 655 80

also I can find SMEG+ non-Navi
v. 52CR1 with spare part number 98 110 661 80

Is it going to work by keeping the same display? The connectors at the back are the same. I tried to talk with 4 different Peugeot distributors here in Greece but no one was able to answer my question. They do not know if it is going to be compatible.
Only one person told me that it should work, but then you have to go to Peugeot service and match new unit with new VIN since the unit is going to beep all the time.

Thank you in advance

Contact me via private message. I might have a solution for your.
 

·
Registered
Joined
·
1 Posts
Hi can anyone help please, just got a 2016 2008, radio and screen keep restarting. Sadly I messed about and screen doesn't work at all, radio dose, but still restarting. Ordered a replacement screen and header unit, where can I get latest software from please.
 

·
Registered
Joined
·
1 Posts
I have a 208 GT-line dated 2015. The car had a recall for a software update last year and I have been having trouble with the radio restarting several times during a journey of more than a few miles. It happens no matter whether I'm listening to FM or DAB. The Software version is SMEG6.1.D.R20 CD:30490 Dated 17-12-15 Bluetooth version software is 1.2.0 and Display version is 40.20

I've tried a factory reset and deleted the bluetooth connection to my iPhone, but it still resets every few minutes.

Is there an update for this as my dealer wants a considerable amount of money to update the radio?

EDIT……..

Update on this, I managed to find SMEG6.4.A.R10 and installed the software on my radio, it would seem that the problem is now solved.

Thanks ;-(
 
481 - 489 of 489 Posts
Top