Peugeot 208 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi folks
Had my 208 GTI since May 2020, noticed soon after purchase the eco function doesnt work when I stop, just get the green light on the dash flashing 3 times, its been back to peugoet to be told I need to turn off my electrical stuff in the car and drive further, this cant be right, must be honest its really putting me off my car.
Jackie
 

·
Registered
Joined
·
12 Posts
d'you mean the stop start function?
mine worked for the first few days then never saw it again. As I understand it, it only comes on when you've done a long journey and charged everything up to the max.
 

·
Registered
Joined
·
2 Posts
First thing I'd check is the battery state of health - if you're doing short trips with everything electrical on its possible the battery could degrade to the point the Eco won't function. Plenty of places can do a load test on the battery and worse case you just buy a trickle charger to protect the battery when it's parked.
 

·
Registered
Joined
·
11 Posts
Hi,
I had the same happen to me.
Unless I done a long journey my stop start did not work.
The dealer said at first it had to do 5000 miles for it to settle which I didnt believe.
Hope this helps
 

·
Registered
Joined
·
1 Posts
Hi folks
Had my 208 GTI since May 2020, noticed soon after purchase the eco function doesnt work when I stop, just get the green light on the dash flashing 3 times, its been back to peugoet to be told I need to turn off my electrical stuff in the car and drive further, this cant be right, must be honest its really putting me off my car.
Jackie
I have the 2015 GTI prestige, I noticed when it is hot it works straight away, however it did not work on my daily commute, only when I did a long drive it turned on and caught me by surprise. After doing some research, the battery has to be at 100% so if left overnight(alarm on etc) it will not work until 100% battery is achieved.
 
1 - 5 of 5 Posts
Top