Peugeot 208 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all-

My family and I recently moved to Portugal from the US and needed to get a new car. After some searching we purchased a new Peugeot 208 Allure 1.2 PureTech, which we're really enjoying on the whole.

Having said that, we are having some consistent issues with the touchscreen and Carplay functionality. I've written up a good bit of documentation about what I've seen and I'm curious to see if other's have had similar experiences. The problem tends to occur when it's hot outside (26C or higher), but it's quite difficult to predict exactly when things are going to stop working. It's not super consistent. Carplay failures can occur with either my iPhone 7 Plus or my wife's iPhone 10.

This is a series of videos to illustrate the problem and that will hopefully help to troubleshoot and resolve them.

2020 Peugeot 208 - Touch screen issues - #1 -
2020 Peugeot 208 - Touch screen issues - #2 -
2020 Peugeot 208 - Touch screen issues - #3 -
2020 Peugeot 208 - Touch screen issues - #4 -

The problems so far are:
  • The touchscreen will freeze and stop responding to touch. The end-result of this is an inability to change the cars temperature, use the radio or any other function associated with the touchscreen.
  • The touch screen has, on a couple of occasions, started to pixelate, lag and look very strange while using Google Maps.
  • CarPlay will stop responding at random times, so Google maps and Apple Music stop being functional.
  • Reconnecting the phone's USB/Lightening cable doesn’t resolve the issue. Restarting the car doesn’t resolve the problem. This has led to some very stressful situations while driving in unfamiliar areas of Lisbon.
Troubleshooting steps taken so far:
  • Turn the car off and on again. No improvement.
  • Replaced the USB cable that I connected to my iPhone. CarPlay is still not working.
  • I tested the problem using both my wife and my iPhones, which are different models. CarPlay still doesn't work. The It's like there's no phone plugged in at all and it's also not being seen through bluetooth.
  • I cooled my phone in front of the air conditioner, in case the problem was my phone overheating. No improvement.
  • I initially thought the CarPlay issues might be the phone getting hot, so I started to keep the phone in front of the AC vents to keep it cold. Even after the phone got cool to the touch there was no improvement.
My thought is that the rear of the touchscreen is elevated on the dash and in the direct path of the sun.

I'll note I did use the search function and really didn't find any contemporary accounts that matched my issues, so it seemed it was worth a new post.

If anyone has any experience or possible solutions, I'd love to hear them.

Thanks!

Lee
 

·
Registered
Joined
·
12 Posts
Hi Lee, So sorry to hear of your problems. Can't offer any helpful solution but you should not have a problem like this with a brand new car. I would suggest you take it back to the dealer and request they replace that unit or at the very least replace the software first to see if that cures the problem.
Hope you get this sorted soon and you can start to enjoy your new car without any problems.
Doug
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
There is a software patch that’s just been released you can download it from the website. That will fix the Touch update
Thanks so much for that information. I looked and didn't see anything that clearly stated it was a newly released update. Do you happen to have a link or a version number?

Thanks again.
 

·
Registered
Joined
·
38 Posts
I cannot find what you mean... appart from that, the version 42.01.72.32 is the firmware version of a NAC WAVE4. The 208 does not mount that unit.
 
1 - 10 of 10 Posts
Top